Access to bridge type Modems

Hi
we have a few modems ( ADSL/VDSL/FiberOptic) that work in bridge mode and there is no any pppoe connection on these devices .
can we gain access to bridge mode devices without any modification even after factory reset ?
most of them is in bridge mode after factory reset and we can’t access to device from ACS and need physical access to create pppoe .
is there any way to access these devices in bridge mode ?

Oh, that does not sound great.

With most hardware suppliers there is an option to create reset resistant configurations.
In that configuration you add a network interface (I use a pppoe dailer with ‘shared’ credentials) and the ACS settings.

If your hardware has been shipped to your customers without that, it will be difficult to fix this afterwards. I am currently in this process. It needs a lot of customer interaction and time. It is not very successful ether.

1 Like

We do exactly this. First, you have to change your CPE config to have two interfaces for each WAN service. One for PPPoE, one for management. Our management network lives in the 172.16. 0.0/12 IP space and gets its IP via DHCP. We hard-code the ACS IP into the CPE, but also send it via option 43. This allows us to switch a CPE from the production to the test network without having to reconfigure it. On the test network, the DHCP server sends a different URL for the ACS.

When the CPE boots up and connects to the ACS the various provision scripts we have check what state the CPE should be in (routed or bridged) and then applies the appropriate configuration to the CPE.

Because the CPEs always have a management connection, we always have access to the CPE no matter what mode its in (routed or bridged). And it also allows me to disable the PPPoE interface when a customer is disconnected for non-payment. This prevents the CPE from hammering on the radius server.

2 Likes

@JonasGhost What issues are you having upgrading CPE config in the field? Which CPE vendor?

The issue is, that I can not access them (yet). The are zyxel devices.

The old configuration was not reset save, but it had a possibility to access the webui over a special IP. It also had no ACS configuration in it.
This was bevor I joined the company.

About 1/4 of the device have a chance of being migrated to the ACS without customer contact, as they still have the pppoe connection.

They new configuration will be uploaded with the help of the supervisor user and the webui. The ACS has a list of serial numbers of these devices. On first contact it will save the configuration the romd.
Fortunately we have a small number of devices of that type.

The device I am using have serial number base passwords and someone published a tool to do the calculation locally.

Thanks all for response . i thought should be a way in modern world to access bridge modems but it’s not !
i tried this way to create managment pppoe with shared info and make device up but unfortunately this config was cleared after factory reset. tested on multiple vendors like huawei , iplink , dlink , tplink , zyxel , … most of them don’t have reset save option .
i think we need an application or a javascript robot for users to execute that and try to make pppoe on modem without user action because most of this customers doesn’t have technical skill even to configure pppoe or login to modem panel .

Zyxel has that option, to make a configuration reset save. This is called romd.
Talk to your zyxel service team, they can set you up with the correct tools for that.
I have also seen that configuration baked into the firmware for large telcos, with huawei, technicolor, adb, zyxel and zte.

With zyxel the tool is called express boot tool, which is build by zyxel for the firmware and hardware version. With that tool, the cpe gets the firmware and the configuration flashed.
You also need some test devices to create the configuration. You will need to send the serialnumber of your test/development device to zyxel.

I think that is in a similar way possible with the other hardware vendors. You need to work with them, otherways it can not work

1 Like

I fundamentally hate how romd works via the ACS. Actually, I despise how Zyxel does their CPE config updating process. Pushing a new config file doesn’t cause the CPE to send a bootstrap event, like every other CPE I’ve dealt with. It also doesn’t cause the CPE to automatically save it to romd, like every other CPE I’ve dealt with.

As detailed as the spec for TR069/98/181/etc is, this is an area that is devoid of guidance.

I hate that when you do a SPV on romd with the value of save it stores the current configuration, not the current config file. No other CPE I’ve dealt with operates like this.

I’m curious how you have solved these issues @JonasGhost.

1 Like

Is it possible to build a vendor config file that saves to ROMD when loaded? Is that what you mean @akcoder - i.e. it saves only running config, not an uploaded config?

We are just learning the nuances of zyxel as well and provision with ROMD initially, and have not learned how to manipulate ROMD via ACS yet.

1 Like

The way ROMD operates is it saves the running config, not the uploaded config. So if you upload a new config, then some other part of the configuration process sets up the PPPoE connection, then something tells ROMD to save, the new default config for that CPE will include the PPPoE connection for the given user.

The way every other CPE I’ve dealt with is uploading a new config automatically saves the config to default.

1 Like

I had bootstrap events, because the old configuration was not not tr069 aware.

The configuration were uploaded with the supervisor user in the web UI.
I had a list of these devices in my provisioning script, so instead of provisioning the configuration was saved to the romd.
At the next inform, the device was fully provisioned.

I am currently experimenting with new zyxel devices and there I would need the possibility the change the configuration over the ACS. I saw the problem with the missing bootstrap event. I need more or less 3 operation modes, with a different configuration file. The configuration should be rolled out over the ACS, if needed.

I’ve gone around and around with my sales engineer at Zyxel. Zyxel (correctly) points out that the spec doesn’t say what to do when a new config file is sent to the CPE. They said “Just detect that its been defaulted some how…”

I made the case that every other vendor I’ve worked with (and they are all fundamentally based on the same Broadcom reference platform) sends a 0 BOOTSTRAP when a new configuration file is uploaded.

After more back and forth, my sales engineer says in the next release the CPE is supposed to send 0 BOOTSTRAP. That is at least for the model I’m using (VMG-4927).