Unable to configure Huawei HG8245W5 as Bridge Mode via ACS

As part of Project, we are trying to automate Provisioning Huawei’s HG8245W5 completely using GenieACS

On the WAN side the ONT has ConnectionTypes listed below:


We have tested IP_Routed as Connection Type and we were able to successfully establish PPPoE directly on the ONT & ONT acquired an IP.

However, now we want to test the ONT as Bridge Mode. Whereby, we are aiming to connect a TP-Link to LAN Port 1 of ONT & Establish PPPoE on TP-Link

Thus, we configured PPP Connection as PPPoE Bridged & Disabled Layer 3 Mode for LAN 1 Port making it Layer 2 / Bridge as shown below:

InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANPPPConnection.1.TransportType = PPPoE_Bridged
InternetGatewayDevice.LANDevice.1.LANEthernetInterfaceConfig.1.X_HW_L3Enable = false

Unfortunately, we are unsuccessful & TP-Link is not able to establish PPPoE and acquire an IP from Provider. Are we missing setting any parameters via ACS to ONT to be set in order to made Bridge Mode work?

To do bridged on all of my devices I have to disable the WANPPPConnection instance and enable a WANIPConnection instance and set that to ConnectionType: IP_Bridge

I don’t have any experience with the Huawei stuff, but I’m going to presume it functions the same

1 Like

I don’t know what is your scenario/objective, so I’m not sure if this is going to help, but we use huawei and we don’t use routers like that one as bridges, instead we use specific devices like Huawei EchoLife HG8310M which, from what I see on the web, they are cheaper than a normal routers.

normally, customer requesting a bridge knows what he/she is doing. As a result, customer must setup PPPoE connection using his/her own device which in turn has no need to connect to the ACS.

I have one of those at home connected to a desktop computer running Slackware which acts as firewall/router.

I do this for one similar model:

    if (m === true) {
      // Disable all LAN services
      declare("InternetGatewayDevice.LANDevice.1.LANHostConfigManagement.DHCPServerEnable", null, {value: false});
      declare("InternetGatewayDevice.LANDevice.1.X_HW_DHCPv6.Server.Enable", null, {value: false});
      declare("InternetGatewayDevice.LANDevice.1.LANHostConfigManagement.IPInterface.2.Enable", null, {value: false});
      declare("InternetGatewayDevice.LANDevice.1.X_HW_RouterAdvertisement.Enable", null, {value: false});
      declare("InternetGatewayDevice.WANDevice.1.WANConnectionDevice.3.WANIPConnection.1.NATEnabled", null, {value: false});
      declare("InternetGatewayDevice.WANDevice.1.WANConnectionDevice.3.WANIPConnection.1.ConnectionType", null, {value: "IP_Bridged"});
    } else {
      // Re-enable all LAN services
      declare("InternetGatewayDevice.LANDevice.1.LANHostConfigManagement.DHCPServerEnable", null, {value: true});
      declare("InternetGatewayDevice.LANDevice.1.X_HW_DHCPv6.Server.Enable", null, {value: true});
      declare("InternetGatewayDevice.LANDevice.1.LANHostConfigManagement.IPInterface.2.Enable", null, {value: true});
      declare("InternetGatewayDevice.LANDevice.1.X_HW_RouterAdvertisement.Enable", null, {value: true});
      declare("InternetGatewayDevice.WANDevice.1.WANConnectionDevice.3.WANIPConnection.1.NATEnabled", null, {value: true});
      declare("InternetGatewayDevice.WANDevice.1.WANConnectionDevice.3.WANIPConnection.1.ConnectionType", null, {value: "IP_Routed"});
      declare("InternetGatewayDevice.LANDevice.1.X_HW_IPv6Config.IPv6DNSWANConnection", {value: now}, {value: "wan1.3.ip1"}); //Set again the lost value

Hello Guys,

Apologizes for delayed response.

I am working for Network Operator, which relies on third-party Partner to provide physical fiber uplink connectivity to the ONT.

ONT itself is preconfigured to serve different services using different VLANs for example VLAN ID :431 for TR-069, VLAN ID :432 for INTERNET & VLAN ID :432 for Voice and so on.

third-party provider takes acs URL & Credentials from us [GenieACS] and configure it on the ONT via which we are able to manage the ONT.

We are usually using the first instance from the WAN Connection for the PPP Connectivity.

Based on feedback, We deleted / removed first instance WANPPPConnection instance and enabled a WANIPConnection instance and set that to ConnectionType: IP_Bridged but still the TP-Link connected to LAN Port 1 of ONT what not able to negotiated PPPoE.

InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANIPConnection.1.TransportType = IP_Bridged

InternetGatewayDevice.LANDevice.1.LANEthernetInterfaceConfig.1.X_HW_L3Enable = false

InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANIPConnection.1.X_HW_VLAN = 432

InternetGatewayDevice.LANDevice.1.LANHostConfigManagement.IPInterface.1.Enable = false