Unable to enable debug log in genieacs server

How to enable debug log in genieacs server? i am able to get [INFO] logs in genieacs-cwmp logs not able to get other logs, wat parameters sents like ways.

See here how to enable debug logs: Too many commit iterations

Is it like Sure.
From admin -> config, set ‘cwmp.debug’ to: what value?
is the device ID?
"id = ‘’ " this one?
if device ID where we will get device ID?

The value for “cwmp.debug” is a filter condition so you could just enter 1 to enable debugging on all devices or the mentioned id=’<device_id>’ to enable debugging just for one device. The <device_id> is the OUI-MODEL-SN string you find at the top of each device page.

Thanks lavira , i will try this on my genieacs server GUI and will share the result

Is this the debug logs we get in ./genieacs-cwmp output?

2020-11-15T12:42:20.044Z [INFO] Worker listening; pid=6109 address=“0.0.0.0” port=7547
2020-11-15T17:49:59.127Z [INFO] 172.16.7.21 202BC1-BM632w-000000: Inform; cpeRequestId="" informEvent=“2 PERIODIC” informRetryCount=0
2020-11-15T17:49:59.296Z [INFO] 172.16.7.21 202BC1-BM632w-000000: ACS request; acsRequestId=“175cd0725c70000” acsRequestName=“GetParameterNames”
2020-11-15T17:49:59.690Z [INFO] 172.16.7.21 202BC1-BM632w-000000: ACS request; acsRequestId=“175cd0725c70001” acsRequestName=“GetParameterNames”
2020-11-15T17:49:59.980Z [INFO] 172.16.7.21 202BC1-BM632w-000000: New device registered

this is the CWMP log … if you enabled debug, you should also have in the environment file a line that defines where the debug file will go:

GENIEACS_DEBUG_FILE=/var/log/genieacs/cpe.debug

In this file you will see all the messages passed between the ACS and the CPE, logged in either yaml (default) or json, depending on the GENIEACS_DEBUG_FORMAT line.

In /opt/genieacs/genieacs.env
below is the content

GENIEACS_CWMP_ACCESS_LOG_FILE=/var/log/genieacs/genieacs-cwmp-access.log
GENIEACS_NBI_ACCESS_LOG_FILE=/var/log/genieacs/genieacs-nbi-access.log
GENIEACS_FS_ACCESS_LOG_FILE=/var/log/genieacs/genieacs-fs-access.log
GENIEACS_UI_ACCESS_LOG_FILE=/var/log/genieacs/genieacs-ui-access.log
GENIEACS_DEBUG_FILE=/var/log/genieacs/genieacs-debug.yaml
GENIEACS_EXT_DIR=/opt/genieacs/ext
GENIEACS_UI_JWT_SECRET=secret

And i made in genieacs GUI in Admin tab
Admin -> config -> added cwmp.debug as 1

but no files i got in /var/log/genieacs folder , this folder is empty

make sure the user on which genieacs-cwmp process is running has appropriate rights on the /var/log/genieacs/ folder … also, you need to restart the genieacs services after every change to the genieacs.env file.

This
root@manjunath:/opt/genieacs# ls -dl /var/log/genieacs/
drwxr-xr-x 2 root root 4096 Oct 30 09:16 /var/log/genieacs/

  1. ./genieacs-cwmp i am running in root only
  2. I restarted server many time

if you run it by hand from the console, you also have to apply the env file, so in order for it to work like this you have to run extra commands (assuming you are using bash as a shell):

cd /opt/genieacs/
set -a
. ./genieacs.env
set +a
./genieacs-cwmp

My advice is to stick to the documentation and use systemd

ok, i will run by systemd
I have one more query i have posted in below link


Please help me in resolving this issue

I created a unit file manually as i was unable to create sudo systemctl edit --force --full genieacs-cwmp from this command
vi /etc/systemd/system/genieacs-cwmp.service
root@test:/etc/systemd/system# vi genieacs-cwmp.service
[Unit]
Description=GenieACS CWMP
After=network.target

[Service]
User=genieacs
EnvironmentFile=/opt/genieacs/genieacs.env
ExecStart=/home/test/genieacs/dist/bin/genieacs-cwmp

[Install]
WantedBy=default.target

This is where the executable present in my case
/home/test/genieacs/dist/bin/genieacs-cwmp

root@test:/etc/systemd/system# sudo systemctl status genieacs-cwmp
● genieacs-cwmp.service - GenieACS CWMP
Loaded: loaded (/etc/systemd/system/genieacs-cwmp.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2020-11-17 16:25:47 IST; 2s ago
Process: 5186 ExecStart=/home/test/genieacs/dist/bin/genieacs-cwmp (code=exited, status=217/USER)
Main PID: 5186 (code=exited, status=217/USER)

Nov 17 16:25:47 test systemd[1]: Started GenieACS CWMP.
Nov 17 16:25:47 test systemd[1]: genieacs-cwmp.service: Main process exited, code=exited, status=217/USER
Nov 17 16:25:47 test systemd[1]: genieacs-cwmp.service: Unit entered failed state.
Nov 17 16:25:47 test systemd[1]: genieacs-cwmp.service: Failed with result ‘exit-code’.

most likely you forgot to create the genieacs user or to set appropriate rights on the folders.
Remove the User=genieacs from the config and do a systemctl daemon-reload && systemctl restart genieacs-cwmp

Thanks lavira ,After removing User=genieacs i am able to run the genieacs-cwmp now.
Need to check on logs Now.

I can able to see the files in /var/log/genieacs/
for CPE logs do i need to check genieacs-debug.yaml this file?

In this file can i only get HTTP request and responses this info i can get from wireshark either , but i want to get debug logs of CPE, so that i can debug the below error
“Cannot read property ‘value’ of undefined” Error