Stun server Help!

I have the GenieAcs server up and running

I tried 3 different Stunservers and I am sure I am missing something.
ACS config - port is 3478

and the stun server shows this:

./server -v -h ... -a ... -p 3478 -o 3479 -m 1000


different StunServer


what am I doing wrong?

Hi mstrolo

how to get these server details, can u pls send command to get details

what do you mean?

I’m using this:
this is my command:
/opt/stunserver/stunserver --primaryadvertised PUBLIC_IP --reuseaddr

This service must run on the same server as GENIEACS.

How do i know its working?

What ports have you opened?

I tried using this also but cpe inthe acs server keeps saying cpe offline when i try to summon

and the service runs in the same server as the acs server

how do you know when its working?

Did you set STUN server on the CPE? You know when it’s working once the CPE has UDPConnectionRequestURL set. Have you tried to make tcpdump on port 3478 to see if CPEs are even trying to connect?

stunserver runs on the same server as the ACS server.
CPE has stun client on it.

can you see CPEs connecting to the stun server?
tcpdump -i any port 3478
and check if you see anything

CPE need’s to configure by itself

Did you put this into the .env file of GenieACS:



now i have this command in the file.
doing reboot to check.

by the way - [coturn] is supported as the stun server?

yes i have a connection

11:35:19.665886 IP > UDP, length 44
11:35:19.681605 IP > UDP, length 88
11:36:19.755827 IP > UDP, length 44
11:36:19.755862 IP > UDP, length 44
11:36:19.770987 IP > UDP, length 88

what needs to be the URL?

in my trace the device is using completely different port as source and not 3478. It seems that negotiation between the device and stun server has failed.

The device should be sending different port as source. This is how the port stay’s open when the ACS tries to send UDP connection request. So either your stun is not configured properly or the device doesn’t work with stun as it should.

What I would suggest is that you try one of the public available STUN servers (google) and try to see if the udpconnectionrequest address will change. This would mean that your stun is not configured properly. If it doesn’t change this would mean that your device is a bit strange.

May I ask which device is this?

i don’t understand

CPE - needs to go out to 3478 no?
in the CPE I have a connection request - something like that

this was wrong as i started the stunserver from there putty that is on the same PC as the cpe.

i can see the router connecting with the stun server