Stuntman -server ,No UdpConnection Url

Hey

  • I’m setting up STUNTMAN -SERVER address
  • InternetGatewayDevice.ManagementServer.UDPConnectionRequestAddress is NOT reported properly by CPE
  • stunserver is running on the same server as GenieACS and have --reuseaddr enabled …
  • cwmp.udpConnectionRequestPort defined as 3478

I am using stuntman-server from:-
https://manpages.ubuntu.com/manpages/bionic/man1/stunserver.1.html

Command used to activate is :-

./stunserver --primaryadvertised PUBLIC_IP --reuseaddr

Port Status Information:-

Config File Configuration:-

Virtual Environment Config:-

Is there any thing which I am missing .

  1. Port address 3478 is not in listening state. (but why). Any reason.
  2. In config ,is I am missing anything.
    Any help @akcoder .

Thanks

Hi,

It goes like this:

  1. only stunserver listens to the UDP port 3478
  2. CPE need’s to connect to the stunserver to port 3478.
  3. CPE will send “4 VALUE CHANGE” inform message to the ACS once the Device.ManagementServer.UDPConnectionRequestAddress is changed.
  4. Device.ManagementServer.UDPConnectionRequestAddress contains also destination port to which ACS needs to send the UDP packet.
  5. ACS will send UDP packet to the CPE from the port 3478 and this is why the REUSE need’s to be enabled.

Basically this is how it works.

Your config seem’s to be fine. So you need to check the following:

  • is the CPE contacting the stun server?
  • does the CPE send “4 VALUE CHANGE” to the ACS?

if this two steps are not met then you have a problem on the CPE itself.

I suppose you’re setting STUN server URL via the ACS?

BR,
Bajo

Thanks @bajojoba
Yes I am setting stun server url via Acs.
I am trying to figure out why udpconnectionrequesturl is blank .

is the “4 VALUE CHANGE” inform message sent to the ACS? you can check that in the genieacs-cwmp logs or via tcpdump.

Hi
I tried a lot ,but no request from device.
I am using Nokia Ont and Huawei Ont and tested on both.

To verify weather my stun server is working properly ,I used https://icetest.info/
Getting proper result.

And On Stun Server, tcpdump command:
tcpdump

Finally stun server is working properly.
No log in cwmp (as usual).

Stun Server Description:
https://www.stunprotocol.org/
Latest stable release: version 1.2.16
Download Link : https://www.stunprotocol.org/stunserver-1.2.16.tgz
Installation: GitHub - jselbie/stunserver: Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest RFCs including 5389, 5769, and 5780. Also includes backwards compatibility for RFC 3489. Compiles on Linux, MacOS, BSD, Solaris, and Win32 with Cygwin. Windows binaries avaialble from www.stunprotocol.org.

What might be the issue ,help.

Network Description:
Stun Server and Genieacs Server both are running on Ubuntu Server 18.04 on Virtual Box(For Testing Purpose Only).
Router is having bind Static IP ,means Nated IP .
192.168.0.4(Ubuntu Server) → 192.168.0.1(Router) ->100.64.45.210(Private IP) ->43.251.93.2** (Public IP ,but it is bind to Private IP .
This is Provide by my ISP.

So can this be a issue as ,bind Public IP is not having a proper subnet mask and gateway.
Just a Doubt.

Thanks in Advance.

Thanks @bajojoba I am getting udpconnectionrequesturl for Dlink and Tplink Router.
So Stun server is working .

Thanks

HI … i have been having similar problems with Huawei ONT it turns out that ONT software we have does not support STUN … so Huawei are going back to R&D . it might be a good idea to verify with them

I changed the stunman server to basic and not full and then it worked for me

Stun Server is working properly .
So problem was with Huawei HG8145V5 Gpon ONT, either this model do not support stun .
Any Idea how this model will support Stun.
Even this model do not support Xmpp Server.

Thanks.