Router Connection

Hello, I am new here, and apologies ahead of time if I am asking a dumb question, which I probably am.

I am running GenieACS 1.2.0 through a docker container with docker compose and all that, and I want to connect a mikrotik router to it. How exactly do I do this? I cant seem to find any tutorials on how to do it, and the documentation goes from installation to provisioning without talking about actually connecting the router to it. So far I have tried running the following command on my mikrotik router through winbox:
/tr069-client set acs-url=https:ServerWhereGenieACSIsRunning:7547 enabled=yes periodic-inform-interval=30s

I don’t know if I am doing anything wrong, or what else there is to do, but the router does not show up in the genieacs gui. One of my collegues thought I might have to set up a user account for it as well but I am not sure how to go about any of that if that is the case.

Any help would be much appreciated.

No user account is needed for a CPE to add itself.

First thing I would do is upgrade to v1.2.5, or git master. There have been a lot of defect fixes since 1.2.0.

I’m not that familiar with the mtik platform, but I presume it wants a full url, and you are missing parts of the URL.

Try this:
/tr069-client set acs-url=https://ServerWhereGenieACSIsRunning:7547/ enabled=yes periodic-inform-interval=30s

Before you enter that command, tail the genieacs-cwmp.log file. The location of which will be dependent upon your configuration. Tailing the log will allow you see any errors that might occur.

If the SSL cert you are using for GenieACS is self-signed, then you will want to disable cert verification in the mtik, otherwise there is a good chance cert validation is what is preventing the mtik from registering with the ACS.