Presets planning for my network

Hello guys, I’m evaluating GenieACS form my network, and I’d like to know your opinion about my planing around Presets.

I have a network for 4 different fiber ONTs (all of the Huawei)
I give the ONT the ACS info via OMCI.

Every client has a different pppoe/password credentials.

My plan is to create inside GenieACS a preset with a precondition equal to the serial number for every CPE, and in this preset put the pppoe/passsword info, plus some WIFI config,.

¿Is this correct or there is another way??

Thank you for you help :slight_smile:

This is a highly inefficient way of setting per-device parameters.

This wiki article walks you through how to create a provision script that can dynamically retrieve information for each subscriber.

I wrote the provision script this example is based off of 8 years ago and its worked flawlessly for me.

1 Like

Thank you! very well explained and the script is very very usefull :slight_smile:

Hi again,
I’m trying a basic script as a starting point but I keep getting an error:

I’m using this script as base: Extensions — GenieACS Documentation 1.2.9 documentation
Script is locate in /opt/genieacs/ext and my env is pointing to this: GENIEACS_EXT_DIR=/opt/genieacs/ext

But I keep getting this error:
default Error write EPIPE 0 23/8/2023, 12:14:12

And from the logs:
Channel has faulted; channel=“default” retries=0 faultCode=“Error” faultMessage=“write EPIPE”

Any help would be appreciated :slight_smile:


Are your calling the right file/function in your ext script?

Hola Felipe,
I’m pretty sure.

My script is the one from the official docs as an example:

Its name is ext-sample.js and the location in the file is: /opt/genieacs/ext witch is the same as my env dir: GENIEACS_EXT_DIR=/opt/genieacs/ext

And this “const res = ext(“ext-sample”, “latlong”, “arg1”, “arg2”);” is fired on every INFORM (for testing porpuses)

I also, remove in my .env the line about the extensions directory, and I put everything in /opt/genieacs/config/ext but I got the same error.

Every change I do I restart the service (as I read on the forum that it is necessary)

I’m really lost here. ¿should I use the lastest code in github of the lastest release? I’m using the release right now.

node version: v18.17.1

Changed to node version v16.20.2, same problem.

¿any idea how to debug this?


Found the problem!
It was a problem related with node because I installed using nvm and genieacs didn’t find the node executable.


1 Like