GenieACS 1.2.1 guide for X MIKROTIK Factory Configuration File

Hello, please need some help for sending “X MIKROTIK Factory Configuration File” to routeros device.

I’ve installed genieacs 1.2.1 from sources ,modified file \ui\files-page.ts at line 52 and file \ui\drawer-component.ts at line 105.

After build and services enabled, “X MIKROTIK Factory Configuration File” appears in genieacs file type select menu. File is successfully sent to mikrotik router (starting session, events: [7 TRANSFER COMPLETE, M Download from logs), but after reset, no changes.

May someone help or give any advice ?


I’m working with Mikrotik RouterOS version 6.47.3 and GenieACS v 1.2.1 and Factory Configuration File overwrite is working fine.

I don’t use UI at all though. Just the API. I push a task with a JSON like this {“name”: “download”, “fileType”: “X MIKROTIK Factory Configuration File”, fileName: “factory.rsc” }

Things that can be helpful

  1. Instead of factory reset, you can test if it works by typing “/system default-configuration custom-script print” on mikrotik cli. This RPC download type does not trigger a reboot on Mikrotik, so it’s pretty easy to test
  2. Look at mikrotik’s logs. What does it says?
  3. Look at packets contents with tcpdump or wireshark
1 Like

Hello @perotta i didn’t use api before. I tried and it works very well. I also tried with gui again and abracadabra, mikrotik factory config file is loaded and applied after reset.

For sure, modding gui source file as i did is sufficient to add X Mikrotik Config file type. I’ll disable gui and bind api with own nodejs/web app.

Thanks for suggestion.