Hi everyone!
I’ve got a very stange problem and I really can’t figure out what is causing it.
My setup:
GenieASC on VM: v.1.1 with GenieACS-GUI
OpenWrt router with EasyCWMP: v.1.8.1

I’'ve successfully registered the CPE to Genie, but I when I press “Refresh” on the device’s page I get “Task queued but not processed”. The stange thing is that if I refresh or edit just one parameter everything works as expected!
I also had to disable ACS to CPE authentication in order to archieve this, otherwise it would throw at me the “Incorrect connection request credentials” error, another mistery.
API requests work, with password too!
I also tried opening the following url in a browser in order to trigger a CONNECTION REQUEST event so that it made the request to Genie and by refreshing the page I could see that the last inform time was updated too. -> url: “http://CPE_IP:7547”. This works event with authentication.


config local
        option enable '1'
        option interface 'eth0'
        option port '7547'
        option ubus_socket '/var/run/ubus.sock'
        option authentication 'Digest'
        option logging_level '3'
        option provisioning_code '456'

config acs
        option scheme 'http'
        option url ''
        option periodic_enable '1'
        option periodic_interval '100'
        option periodic_time '0001-01-01T00:00:00Z'

config device
        option oui 'FFFFFF'
        option serial_number 'FFFFFF123456'
        option product_class 'Generic'
        option hardware_version 'v0'
        option software_version 'SHRW-0.2_04-2019'
        option manufacturer 'OpenWrt

-> GenieACS
“MONGODB_CONNECTION_URL” : “mongodb://”,
“CWMP_PORT” : 7547,
“CWMP_SSL” : false,
“NBI_PORT” : 7557,
“NBI_SSL” : “false”,
“NBI_LOG_FILE” : “/var/log/genieacs/nbi.log”,
“NBI_ACCESS_LOG_FILE” : “/var/log/genieacs/nbi-access.log”,
“FS_PORT” : 7567,
“FS_LOG_FILE” : “/var/log/genieacs/fs.log”,
“FS_ACCESS_LOG_FILE” : “/var/log/genieacs/fs-access.log”,
“DEBUG” : true,
“LOG_INFORMS” : true,
“CWMP_ACCESS_LOG_FILE” : “/var/log/genieacs/cwmp-access.log”,
“CWMP_LOG_FILE” : “/var/log/genieacs/cwmp.log”,

Additional info:
-> GenieACS debug file for CPE
Procedure followed:

  1. Start easycwmp on OpenWrt, wait for PERIODIC inform
  2. Press Refresh on Genie and wait for response from CPE (genie thows the “Task queued…” error)
  3. Rrefresh Device.DeviceInfo.ProvisioningCode, no problem here

[](link to file)

->cwmp-access log from Genie

I really hope someone can figure this out and help me.
Also, I’ve already tested GenieACS with MikroTik and never had problems like this one.

Thanks in advance, have a good day!


I suspect the device is just too slow to initiate a session after a connection request and/or taking too long to process the queued requests. Try setting ‘DEVICE_ONLINE_THRESHOLD’ to a value higher than 4000 which is the default. That’s how long the API will wait for the device from the start of the connection request until the TR-069 session should have closed successfully.

Sure, as soon as I can I’ll try and let you know the results!
Than you very much!

Hi, I’ve finally checked!

The problem is not solved. If I press the refresh button the same error shows up: “Task queued but not processed”. By refreshing the page (F5) (after 10s or so) I can see that the CPE refreshed the parameters and went online.
I tried using Wireshark to see what is happening but I never used it and I don’t really know much about http connections/protocols, etc…


Wireshark output

I’ve also got an authentication problem:
I get the error: “Incorrect connection request credentials”.
By looking at Wireshark’s output I saw that when it said “username” there was an empty string. So my suspect is that maybe Genie isn’t authenticating to the CPE.

Wireshark output

Thanks for the support, I really hope you can figure out this mess.

Have a good day

What value did you use for DEVICE_ONLINE_THRESHOLD? Looking at the pcap file I see the session is taking over 8 seconds in total. So maybe set that to 10000.

You kinda need to get your hands dirty with HTTP and TR-069 to troubleshoot device issues. I can only maybe provide tips but I can’t troubleshoot issues for you, especially CPE issues.

Create a preset to set ConnectionRequestUsername and ConnectionRequestPassword params.

I’ve tried setting it to 30000 too.

Sure, I’ll see what I can manage to do.

Didn’t think about this.

I’ll try everything and if I can find a solution I’ll let you know!

Thanks for your beautiful work!

1 Like

Hi Zaid,

Using 1.2-beta, we are losing contact to CPEs that are online but being pooled into the “Other” online status. GenieACS will not respond to the “inform” request, and does not complete a “summon”. I can see the device respond to the 30005 summon request, but the summon still fails.

Also, I see a constant request being sent to my GenieACS server from the CPE, but the server is not responding.

Where can I find the “DEVICE_ONLINE_THRESHOLD” configuration in version 1.2-beta?

Thanks Zaid,


Hello all,

Having the same issue I would like to know where the “DEVICE_ONLINE_THRESHOLD” can be modified in version 1.2-beta.
Someone has the answer?


I don’t have v1.2 installed to be able to point you to the exact screen. But somewhere in the UI for 1.2 you can set config parameters, this is where you’d add/change this option.


This post describes how to change the parameter you desire:

Yes that’s it! Thank you a lot.


1 Like

Hello acoder

Thanks your useful tips about these 3 configurations deviceOnlineThreshold & connectionRequestTime. I am a new user to genieACS 1.2. but seems these configuration and another connectionRequestAuth provided by zaidka. it can resolve the “server is unrearchable” issue i meet afternoon.

at here, really thanks your valuable tips. Would you mind tell me why these 3 parameters via config/tab can fix “server is unreachable” issue. which source file in genieacs will use the 3 parameters? I want to understand root cause.