Configuring Genieacs 1.2.0-beta


I was using the older 1.1 version and then I just installed this one … The older one had a config.json file to configure can anyone please tell me how to do the same in this one. Might be a lame question for many people here but I am just new to genieacs and kinda still not used to it.


I would start with the docs which provide the following answer regarding the configuration variables that were previously found in config.json

Create the file /opt/genieacs/genieacs.env to hold our configuration options which we pass to GenieACS as environment variables. See ( section for a list of all available configuration options.

1 Like

You can keep your existing config.json file in v1.2. However I would recommend that move your config to environment variables as @ianbmacdonald said. Note that certain options are not available as environment vairables but have instead been moved to the databsae (under admin -> config tab). Here’s the full list of these options and their equivalent in the database:

DOWNLOAD_TIMEOUT: cwmp.downloadTimeout
DEBUG: cwmp.debug
RETRY_DELAY: cwmp.retryDelay
SESSION_TIMEOUT: cwmp.sessionTimeout
CONNECTION_REQUEST_TIMEOUT: cwmp.connectionRequestTimeout
GPN_NEXT_LEVEL: cwmp.gpnNextLevel
GPV_BATCH_SIZE: cwmp.gpvBatchSize
COOKIES_PATH: cwmp.cookiesPath
DATETIME_MILLISECONDS: cwmp.datetimeMilliseconds
BOOLEAN_LITERAL: cwmp.booleanLiteral
CONNECTION_REQUEST_ALLOW_BASIC_AUTH: cwmp.connectionRequestAllowBasicAuth
MAX_COMMIT_ITERATIONS: cwmp.maxCommitIterations
DEVICE_ONLINE_THRESHOLD: cwmp.deviceOnlineThreshold
UDP_CONNECTION_REQUEST_POR: cwmp.udpConnectionRequestPort

The value should be an “expression” which is a new format that I haven’t yet had the time to document. For now you’ll probably get by using numbers, boolean (true/false), or quoted string literals ().

1 Like

ran into something i am not sure what is happening … I am unable to login with valid credentials with a following error

UI_JWT_SECRET is not set

I read about this and it says that it has something to do with the browser cookies… So I wiped off everything and tried to log in … same issue persists… please help
please help