Can't run a single provisions

hello, first of all, I’m new to genieACS, I apologize in advance if my problem seems to be uncomplicated, i have no idea how to run my provisions;
I followed the documentation, i read the Example of a provisionned flow of Mister Akcoder, i read a lot of topic in the forum and still not finding the solution, i’ll show you my provisions and preset and devices:




my problem is that i could’nt run a single provisions, i tried to play with Tags on devices, i changed my preconditions and events and i have read Logs from genieacs-cwmp-access.log and genieacs-ui-access.log and nothing appeared there (or maybe i don’t know what to check in Logs), i’m stuck and i really need help please !
Thank you in advance

-Aziz

  1. genieacs version? Upgrade to latest if necessary.

  2. the only situation I know that prevents a provision from running is when you get a CPE fault. Clear them if you have any.

  3. enable debug. you should be able to see CPE traffic when it happens. tail -f is your friend. (cwmp.log also have traffic but debug could tell you the specifics of a CPE fault, if any).

https://docs.genieacs.com/en/latest/environment-variables.html

  1. and now for an stupid question: have you rebooted the server?

Worst case scenario, I suggest doing a mongodb backup, then remove all presets and leave only 1 with no events pointing a single provision which simply does a log. Then check cwmp logs. If the most basic test fails then I recommend starting all over. Ie: reinstall genieacs on a new linux install.

I’d remove all off your presets and provision scripts except for the stock ones (bootstrap, default, inform). And start all over. For events, you do not need to specify every event the CPE sends when booting. So for your scripts like first-bootzii and others like it, change the event to M Reboot, or even 1 BOOT if you only need to trigger on boot. I’ve haven’t had a need (yet) to trigger any of my presets on M Reboot, only 1 BOOT.

Hey, thank you so much for your precious answer @rudymartin & @akcoder and i apologize for this late answer, i was really sick.

1.My genieACS version is the latest version so i don’t think that it’s the problem.
2. If you are talking about the fault that can be found in fault section on genieacs pannel, there is none !
3. how can i enable debug ? and also i didnt found any file named cwmp.log, can you send me the path ? the only log file that seems to be similar is the one that i mentionned it in my previous message.
4.i don’t know if i have the permission to reboot the server (i’m actually an intern in a company, so i would like to let this option at the very end)
5. as @akcoder suggested me, i removed every single script and presets et start all over, and i didnt find any changes, my problem is still persists, or maybe as i mentionned it before, i’m not watching the good logs.
is there any helps for my problem please ?

  1. Never forget to mention your context. Your screenshots are not helping you. Either you screw up during install or you did something to it, so IMHO I suggest to reinstall on a clean Linux installation. From scratch, with no data restore (you only have 7 devices).
  2. That’s why I gave you a link. cwmp.log was an abbreviation of mine on the spot in order to avoid writing the full path is /var/log/genieacs/genieacs-cwmp.log
  3. I recommend using a dedicated machine for this. A virtual is better. Using a production server for a testing? Not good.
  4. looks like 1 to me. You know most logs are usually located under /var/log.