Auto-set GenieACS Server in TR-069 package of MikroTik client

Good morning,

I’ve got a GenieACS server up and running. I would like to receive the ACS IP automatically through DHCP so that it automatically fills in the field “ACS URL” of the TR-069 package.

In order to do so, I’ve set up a DHCP server with the option 43 in place. As I capture the traffic with WireShark, I see that the option is actually being sent to the MikroTik. However, the CPE doesn’t do anything with this information. Therefore, the Tr-069 package does not receive the ACS URL.

I was therefore wondering how could I transmit the ACS URL through DHCP so that it fills in the ACS URL of the TR069 package.

Thank you very much,

if you manually configure the ACS url to the CPE, do you get a BOOTSTRAP event? (genieacs-cwmp.log)

Hi, rudymartin, thank you very much for your answer.

Yes, if I type in the address manually, the server detects the CPE without any problem whatsoever. So my guess is that there’s something wrong with the way I’m computing the DHCP option.

The procedure with which I’m computing said option in the DHCP server is the following:

If the IP is http://:7457 (let’s suppose the entire string’s size is 25 bytes) I convert it to hex. Subsequently I put in the prefix “01” followed by a “19” (since it’s 25 bytes). Therefore, we have 0x0119<hex_conversion>. When I capture the traffic with Wireshark I see the option being sent in a DHCP_OFFER. I was therefore wondering if there’s another way with which I could accomplish this task, or if perhaps I’m doing something wrong.

Thank you very much again for your your attention.

What dhcpd server are you using? We are using ISC and have configured option 43 as below. You will probably need to send rfc3442 (classless static route) as well to force the CPE to create a route back to your ACS ip.

  option tr069.acs-server-url "https://172.x.y.z:7548/";

  subnet 172.27.240.0 netmask 255.255.240.0 {
    interface eth1;
    option subnet-mask 255.255.240.0;
    option broadcast-address 172.27.255.255;
    option routers 172.27.240.1;
    option rfc3442-classless-static-routes 32, 172, x, y, z, 172, 27, 240, 1;
    range 172.27.240.10 172.27.255.254;
  }

Hi, akcoder, thank you for your answer.

I am using the MikroTik RouterOS implementation of the DHCP server and client. However, I can’t get it to work.

The last time I do this i remember to create an .alter file and push this to the CPE via provision there was a forum discussion in mikrotik that somehow detail this process but indirectly

https://forum.mikrotik.com/viewtopic.php?t=172399

Another approach will be flashfig to create minimal set of config with mikrotik