Unable to refresh InternetGatewayDevice root tree

GenieACS v1.2

when I choose to refresh the InternetGatewayDevice parameter, it goes to “Queued”, I then hit commit which moves it to “Pending” and then immediately to “Stale” with a message that the device is offline.

I’m not sure where to start looking, any thoughts?


Try to add in config tab a value for this parameters and test playing with some values. There is no much documentation about how it works… im a begginer for this…

cwmp.connectionRequestTimeout “512”
cwmp.deviceOnlineThreshold “32768”
cwmp.downloadTimeout “32768”
cwmp.maxCommitIterations “128”


Ok, that seems to have done it. I will tweak a little, but the refresh is working.



Please clarify:

  1. When entering this via the Config editor should the values be enclosed in double-quotes or just naked numbers (it accepts either)?

  2. What are the units of the first three parameters (seconds, ???, seconds) ?

Based on experimentation, the units of cwmp.deviceOnlineThreshold are milliseconds.

This was the only parameter I need to add via Admin | Config | add new/edit.

For my CPE:

  • To make Summon reliable I had to set it to 8000 (8s)
  • To make Device refresh reliable I had to set it to 17000 (17s)

Thank you for the hints.