Change WAN connection from PPPoE to DHCP

I want to change the connection type from PPPoE to DHCP through ACS.
I changed this valuse (Device.IP.Interface.6.X_TP_ConnType) to DHCP or Dynamic IP not nothing changed.
Is there any way where in we can add a new interface for DHCP or on the current PPPoE interface change the connection type to DHCP.

not sure for 100% now, but i guess its interface number 6 is tplinks hardbound to connection type of pppoe, thats why you cant change X_TP_ConnType no any other value

you better check interface number 1 or number two, 1 is static ip and 2 is hat to be dhcpclient

if you read tplinks reduced_data_model_decrypted.xml - file, you can notice that parameter X_TP_ConnType is set to read only

Thanks for the reply @collerok . I managed to change the ConnType from PPPoE to DHCP but it does not change the connection type on the router UI. It stays as PPPoE but other parameters such as username, password and VLAN disappers and we lose connection.

The easiest way to sort this out is to setup the CPE with PPPoE, then in GenieACS refresh all the device params. Then use the API to capture all the data for your router.

Then via the UI of your router, switch it over to DHCP, verify everything works correctly and repeat the refresh of params and capturing of all the data for your router. Then use something like to diff between the two files and see what actually has to be changed to switch a router to DHCP.

We are using declare(“InternetGatewayDevice.WANDevice.1.WANConnectionDevice..WANIPConnection.”, null, {path: 1});
To add a new WAN interface but it does not get created. We want to add a new interface and then delete the old one.

Its not getting added because your syntax is invalid. See this post for valid syntax

You should add A DHCP WAN,and del the old one. Make sure your delete PPPoE and Enable DHCP in one session, or you’ll lose connect.

To Add DHCP with no vlan, is like this:
InternetGatewayDevice.WANDevice.1.WANConnectionDevice.{i}.WANIPConnection.1.X_TP_AddressType==DHCP (string)
(3)then set:
InternetGatewayDevice.WANDevice.1.WANConnectionDevice.{i}.WANIPConnection.1.X_TP_ServiceType==Internet (string)
InternetGatewayDevice.WANDevice.1.WANConnectionDevice.{i}.WANIPConnection.1.Enable==Truev (boolean)

we managed to get things working.

Now the next task is… we are able to ping the router and genie acs also shows the ping response. but when we summon the device says offline. what are we missing.

Could be authentication. Could be request/session timeout. Start by verifying ACS → CPE authentication works.