Tags are not being set on cpe

I’m having a really annoying issue on the past few versions of GenieACS: It stopped setting tags on some cpe’s (not all…).
Scripts run just fine, but the tags defined at the end are not being set, for instance:
declare(“Tags.inHome-static-config”, null, {value: true});
I no longer see the tags in the data-tree of the device either.

I have this issue on 2 different installations and I have no clue as to why it started happening. The end result is that scripts just run endlessly.

@zaidka help! :slight_smile:

I can, apparently, set tags in the gui, it’s just the scripts that stopped working properly.

@zaidka from what I can see it seems that Genie is having trouble setting tags when it is too busy. I see that bootstrap finishes and reads the cpe. After this we have a provision (tagProvisioningCode) that reads “provisioncode” and creates a tag that will trigger the next provision. This script runs, but after this all(!) the relevant scripts for this cpe runs and no tags are being set. If I disable all scripts after “tagProvisioningCode” things seem more stable and Genie is able to set the correct tag

Sorry I wasn’t able to look into this at the time then completely forgot about it. Are you still having this issue? Can you provide a set of presets and provision scripts that I can use to reproduce it?

I think we solved it, but it’s a strange issue. We have an ext script that gets called to deliver values for further config uration of the cpe’s and this is where it spins out. All the scripts work, but it seems as if Genie is unable to “finish up” and store the new state with tags and all. It just keeps running and running and never sets the tags. However, if I manually set a couple of them it seems to be able to get the rest in place. We moved some of the functionality out of Genie and let our system set 1 of the tags and it solved the problem.
I can try to outline the process and send you some of the scripts in a DM.