Provision scripts are not working for me

Hello, I want to execute the getParameterAttributes() RPC. I read on another post that this is only possible using Provision scripts. I tried to write one

declare(“Device.DeviceInfo.Manufacturer”, {path: 1});
var paramNames = [“Device.ManagementServer.PeriodicInformInterval”];
var paramAttributes = getParameterAttributes(paramNames);

But I clearly don’t know what I am doing. Can anyone please help? I already tried going through the wiki and any forum discussions (that is where I got the hint for the above code). Can anyone please help? Also is a setParameterAttributes() possible?

Thanks a lot in advance

read this. make sure you have a preset pointing to your provision.

Hi. Yeah, I had read the Provisions document but hadn’t found anything relevant to doing a getParametersAttributes. i do have a Preset pointing to the Provision. I had to change the channel to “inform”, and it works now. I found the notification command from one of Zaidka’s answers… on using that, I can see that the GetParameterAttributes packet is going out towards EasyCWMP. Is there anything similar for setPrameterAttributes as well? I can’t find it.