Issues working with STUN server (Genie version 1.2.5)

Hi dears,

I’ve installed GenieACS version 1.2.5 and I want to handle some router behind a NAT.
I’ve installed the stuntman server in the same server that I have the GenieACS, executed with with “–reuseaddr” switch and configure the at the same port that stuntman listen in Config area at cwmp.udpConnectionRequestPort parameter.
After checked that the router complete the
InternetGatewayDevice_ManagementServer.UDPConnectionRequestAddress with the IP/port answered by the stun server, I can’t see in the traces or logs any request http from the configure UDP to the router send by GenieACS.
After activate the debug and force a summon for the device from the UI, I see this message in the debug log:

event: outgoing HTTP request
timestamp: 2022-11-14T03:30:15.125Z
remoteAddress: 192.168.30.20
deviceId: 50E039-WAP6807-S212E33000509
connection: null
remotePort: “7547”
url: /CWMP/ConnectionRequest
headers:
host: 192.168.30.20:7547
error: socket hang up

That it’s the information that the router provide in the parameter InternetGatewayDevice.ManagementServer.ConnectionRequestURL (192.168.30.20 it’s the IP of the router in the network behind the NAT)

I can’t understand what it’s missing to make it work (I found some thread mention that in v1.1 this configuration works perfect but found some issues in v1.2.5, thread => “STUN Issues with 1.2.5”)

Has the version 1.2.5 some issue with this configuration or just I’m doing wrong or could be a missing configuration?

Thanks in advance four your help!

If you control your network end to end you can use zerotier for you to solved NAT issue just an idea

what is zerotier and any cpe supports it?

Zerotier is an SDWAN technology allows you to route the traffic from Genieacs back to your private network assuming you have control of your network you don’t need to install zerotier client in the CPE but a proper routing is required in your network.