GeniACS and NATed devices


I’ve installed GenieACS version 1.2.9 on Debian 11 and I want to handle some router (TP-Link TL-WR850) behind a NAT.
I tried stunserver and coturn STUN servers, but for some reason it doesn’t work.

In the Genieacs UI I added the cwmp.udpConnectionRequestPort parameter as shown in the following picture:

I ran the stunserver as follows:

./stunserver --primaryinterface ens18 --reuseaddr --verbosity 3

The error in GenieACS is:

Can You help me to resolve this problem?

Best Regards,


GenieACS and STUN server are installed on the same server.

I have 2 scenario:

SCENARIO 1- the client router is connected behind a DHCP server - two-way communication does not work with this (GenieACS reads the data, but I cannot change anything)
SCENARIO 2 - the client router is connected directly with PPPoE. that’s all right.

In the case of SCENARIO 1, I see in the base station router that theoretically there is communication on port 3478 between the client router and GenieACS.