Huawei EG8141A5 not showing the WAN access control menu

Hi lads,

I want to control my ONU remotely but my EG8141A5 has not WAN access control menu.

Any help is highly appreciated.


not 100% sure about this but you might be using a wrong user. We are using 8145A5 and default admin user is adminep or epadmin. You should be able to see another option with a similar name: Precise Device Access Control (that’s what the menu says anyway). In our case we only allow access by VLAN.

Hi Rudy,

Cheers for your output, I’ve tried adminep, epadmin and telecomadmin but no joy.

yes I want to unable the Precise Device Access Control but unable to get to this menu.

see if you can get these paths

    declare( "InternetGatewayDevice.X_HW_Security.AclServices.AccessControl.AccessControlListEnable", {
        value: )
    }, {
        value: true
    } );
    declare( "InternetGatewayDevice.X_HW_Security.AclServices.AccessControl.List.*", null, {
        path: 0
    } );

in our case WANIPConnection.1 refers to our VLAN:

    cadena = "InternetGatewayDevice.X_HW_Security.AclServices.AccessControl.List.[";
    cadena += "Mode:0,";
    cadena += "Priority:1,";
    cadena += "ServicePort:\"TELNET,HTTP,SSH,FTP,ICMP,SAMBA\",";
    cadena += "SrcPortType:2,";
    cadena += "SrcPortName:InternetGatewayDevice.WANDevice.1.WANConnectionDevice.1.WANIPConnection.1";
    cadena += "]";
    log( "cadena: " + cadena );

    declare( cadena, {
    }, {
        path: 1
    } );

Top man…

But I wouldn’t know where to start. :upside_down_face:

what version of GenieACS are you using ?

[SOLVED] just updated the firmware and its now showing the control access menu, if anyone needs it let me know…

Thanks everyone that got involved. :slight_smile: