Grandstream HT812 - Missing parameters


I have successfully installed GenieACS 1.2.0-beta.0.

I configured a Grandstream HT812 test unit to connect to the server.

The device shows up under Devices but on the device page non of the parameters acually used to configure the unit shows up. The entire tree under “Device.Services.” is missing.

Shouldnt the ACS send a GetParameterNames message to the device and create a list of configuration parameters?

No, this is by design. If you want to get a list of parameters, you need to either manually refresh that node, or us a provision script that does this:

declare("Device.Services.*", {value: 1});

The 1 is parameter age. I.e., that parameter will never be refreshed by the provision script again.

To force a parameter to be refreshed, the value has to be > the last timestamp (in epoch) of when the parameter was refreshed.

You can use this to refresh values periodically, but not to often. Here I use this provision to refresh the LAN data every 6 hours:

let now =;
let oneHour = 60 * 60 * 1000;
let sixHoursAgo = now -  (oneHour * 6);

//Refresh the eth ports
declare("InternetGatewayDevice.LANDevice.*.LANEthernetInterfaceConfig.*.*", {value: sixHoursAgo});


I tried:

declare("Device.Services.*", {value: 1});

But I got in the parameter list was “Device.Services” and nothing that I could configure.

You mention that I can manually refresh the node. How do I do that? :slight_smile:

Try this:

declare("Device.Services.*", {path:, value:});

In the GUI you can click the refresh link next to the node. Oh, your using v1.2. I’m not sure in there, I haven’t used the new v1.2 stuff yet. But the provision script above will work.

You can also use the API to refresh an object, get/set param, etc.


Maybe it dosen’t work with 1.2 yet, it is a beta after all.

I got two more trees under Device.Services now:

But I know there is loads more.

If I press the refresh-circle at one of these trees the refresh is places in queue.
When I commit the queue nothing happends more than a green message saying the refresh was processed.

Try this:

declare("Device.Services.*.*", {path:, value:});

Huhh, that’s wierd.

Started ngrep om the acs server and saw loads of tr-069 traffic and a complete list of parameters in XML.

Refreshed the Device.Services a couple of more times and each time i got “No contact from device” but I saw the traffic in ngrep.

Then I saw that more and more parameters and trees showed up in the list.

Maybe there are to many parameters in the cpe? It’s too much maybee?

Hi, I got the same Issue in my Lab. I was trying

firstly I tryed via Script to refresh the large node for Voice provisionning.



that not worked for me. I tryed to refresh from GUI the whole tree and i Saw in the log there the cpe was sending the Data’s but after a while came the error “No contact from device”.

After a while ( I dont changed nothing ) I was able to see the tree. Maybe there is a internal delay for showing fresh scanned trees?

Look in the logs. I bet the task was retrying repeatedly and timing out.

In the old documentation i grep this:


Value in seconds. Defaults to 30. Increase this value as a last resort if you have timeout issues with your CPE. Try setting the GET_PARAMETER_NAMES_DEPTH_THRESHOLD value to 2 first, then 3 if you have to.

can we still use this Variables in 1.2 ? in the new Version the layout of environment Variables have GENIEACS_ Tag


Add an option in config tab for ‘cwmp.sessionTimeout’. The old SESSION_TIMEOUT still works though, both as env var or config.json.