GenieACS Push File

Hello,

I built and deployed the latest version of GenieACS. I have openwrt with easycwmp running and connected to it. I can perform device reboots and other functions. When I try to push a file I get an error in GenieACS

task_5dc1c0840b855d11d91bc3f0 script.Error Invalid arguments 1 11/5/2019, 10:41:15 AM

I’ve tried capturing HTTP data to determine what is going to my cwmp but I don’t see any traffic with the file information in it. I suspect this error is happening in GenieACS.

I also tested the download directly from my wrt/cwmp device with the easycwmp download command which was successful. I verified that I’ve got the FS_IP and FS_HOSTNAME and FS_PORT params in my .env file as well.

What am I missing?

Detail from faults page:

name: Error
message: Invalid arguments
stack: |-
Error: Invalid arguments
at download

Mike

Can you share the code/script you are using to push the file? I presume you mean push a firmware/config file to a CPE?

I just tried through the UI, under a device I clicked “Push File” and selected a file I’d uploaded to GenieACS in the admin tab.

Which version of GenieACS are you using?

Just built from latest from the repo. Does the push file functionality only work using code in provisions?

I do not use 1.2 (which is in beta) so I’m not able to assist you with this. Sorry.

Appreciate your time anyway. I figured out how to do it with Provisions using the scripting but the ad-hoc push file doesn’t work. I’ll see if I can get it running locally so I can debug.