Cannot use presets with provisions

Hello, sorry for noob question, but…
I’ve install latest version from git with new ui.
It’s wonderful but I cannot use presets. It’s just doesn’t work.
No device has tag. what am I doing wrong?

I’ve tried to add events “1 BOOT” or “2 PERIODIC” but no luck


I believe that’s bug. Empty preconditions are evaluated as false. Will fix soon. For now you can use “true” (no quotes) as the precondition.

Oh. very nice! it’s work now :slight_smile: thank you very much :slight_smile:

What would be a valid precondition expression e.g. to negativ match a tag = “firstInform”?

I tried _tags != firstInform without success

(preconditions must be valid expression)


Tags.firstInform <> true


Tags.firstInform IS NULL

Actually I believe the first one will not work because comparisons against null parameters is always null (just like in SQL).

working, thank you.
Logical combination like
<Tags._FI IS NULL AND Tags._provReady IS NULL AND Tags._registered IS NULL>
are also working.