A sneak peek at GenieACS’s new UI

#1

I have just published a blog post about the new UI we’ve been working on to replace genieacs-gui. Read about it here: https://genieacs.com/blog/2019/03/31/new-ui-sneak-peek/

4 Likes
#2

Thank you, Zaid. Hope to see it released soon!

#3

Is possible to test it ? I saw a code on the GitHub but I don’t know how to get it to my install of genie 1.1.3.

thanks

#4

Sure. Get the latest code (master branch) and run:

npm run build

This will generate a build for you under ‘dist’ directory. Run the binaries from there.

Keep in mind that this is still alpha quality so definitely don’t use in production. You may not be able to revert back to v1.1 without wiping out your database.

#5

@zaidka thank you, i will install new test development for that.

#6

Looking forward to this! Great work all!

#7

I am getting message

UI_JWT_SECRET is not set

where can i specify secert ?

Thank you

#8

Set it in config.json.

#9

@zaidka thanks I added, but what is the default user and where specify more user ?

I installed new clean install from github

i ran npm install

then i can ran npm run build what added dist folder, than i tried to run scripts from bin, but i got an error

Error: ENOENT: no such file or directory, open '/opt/genieacs/dist/bin/config/config.json'

so I copied config folder to bin folder. After this i can start scripts, and get to the UI, but i can not log in with admin admin, what was default user from previous version what i think.

Can you help me with this ?

Thanks

#10

I forgot to mention that you need to run ./tools/configure-ui.

Should copy config/config-sample.json to config/config.json then run the bin like:

./bin/genieacs-ui

This is due to a bug now where it looks for the config file relative to CWD.

#11

@zaidka fantastic, i am in… its looking fantastic :+1:

1 Like
#12

Afer installation 1.2.0-dev, when I try to run ./bin/genieacs-cwmp or other executables I’ve got:
root@acs01:/opt/genieacs# ./tools/configure-ui
/usr/bin/env: ‘node -r esm -r ts-node/register/transpile-only’: No such file or directory

node / ts-node / typescript are installed and I can execute them from command line
in my /opt/genieaces/node_modules exist ts-node/register/transpile-only.js also
my linux is ubuntu 18.10

#13

Run the one under ‘dist’ directory.

#14

@zaidka

hello, so i am testing new version and i want to know if will be in this update some support of TR-181 which is using mikrotik, i know that is possible to get info throught TR-181 model from mikrotik to genieacs, but i have a question about some aliases or something how to can have for example Huawei ONTs together in one install with mikrotiks.I mean overview page etc.

Thank you.