Ubuntu install issue

Hello, I hope everyone is well.

I have a problem while installing GenieACS on my raspberry.

First, here are the versions I use:

Raspi 4B with 4Gb of RAM, Ubuntu server 21.10
Node: v14.19.0
MongoDB : v4.4.12

I followed the installation guide provided by GenieACS:
( https://github.com/genieacs/genieacs/blob/master/docs/installation-guide.rst )

But I can’t get the GenieCWMP and NBI services to start, it returns this error :

I tried to redo the installations in root and not root mode, and it returned the same error.

I even tried to install with the recommended version of NodeJS, and it gives me the same error.

Can you help me with this error, please ?

You have an error: “No such file or directory”,
did you check if /usr/bin/genieacs-cwmp file exists?


Yes, I looked at the files and they don’t exist, did I miss a step in the installation of GeniaACS so that these files were not created?

Try to locate “genieacs-cwmp” file: find / -name “genieacs-cwmp”
and change this file location in systemd service: sudo systemctl edit --force --full genieacs-cwmp

Check also, if genieacs.env is in correct location.

1 Like

Hello, I’d like to come back to you because everything is now functional.

The command to locate the file helped me a lot (thank you :slight_smile: ) because the file was stored under “/usr/local/bin/genieacs-cwmp” and not “/usr/bin/genieacs-cwmp” so I just changed the location of the file in systemd and everything was working.

Thx !

1 Like