Too many commit iterations

I’m having some trouble with "Channel has faulted; channel=“default” retries=0 faultCode=“too_many_commits” faultMessage=“Too many commit iterations” in the new beta. The provision is not that big and worked in the previous version.
I seem to remember that I tweaked SESSION_TIMEOUT (maybe?) to deal with this in the previous version. Might have been something else, but the question is how to tweak my way out of this.

I have the same problem. A refresh of one parameter results in many many acsRequestName=“GetParameterNames” until channel has faulted.
I tried tweaking with
but same result.

I went a bit over board and did this in genieacs.env on the beta:

That seems to have eased the pain a bit. It still faults when I try to refresh the entire device-tree of a cpe, but at least I’m able to provision them without crashes.

Did that used to work in v1.1 without throwing a fault? Can you share traffic capture or debug log?

SESSION_TIMEOUT I believe shouldn’t any effect on this.

MAX_COMMIT_ITERATIONS definitely does. Have you tweaked that option in your v1.1 config before? I don’t see how it could have worked fine in v1.1 but not in v1.2 unless that’s a bug in v1.2.

MAX-COMMIT was tweaked before, but didn’t get transferred as I had the old in a docker container and the new beta installed regularly. I remembered it as I read the other answers in this thread.
It seems to be ok now, but it still freaks out if I try to refresh the entire device tree of a device. I’ll have to trial and error a bit to see what sticks.
I guess I can remove SESSION_TIMEOUT then?

With regards to this particular issue, yes.

I´ll send you the logs. Can you guide me how to enable logging for a device in 1.2?

Sure. From admin → config, set ‘cwmp.debug’ to:

id = '<your device ID>'

This will tell Genie to dump debug info to the file specified in your GENIEACS_DEBUG_FILE env var.

1 Like

Thank you. If you need anything else please let me know. Traces are on our pastebin:



So, have you fix this problem ?
I encounter this problem too.

Couldn’t reproduce the problem. What parameter were you attempting to refresh?

Hi, it was a summon. But it does not matter which parameter, it always end up in too many commit iterations.
Is there anything I can do to investigate the behaviour?

Can you reproduce it using genieacs-sim?

Didn´t use it so far, I´ll try.

can not reproduce it with genieacs-sim :frowning: Is it possible to extract data model from CPE connected to version 1.1.3 for reference?

<00040E-FRITZ%21Box-00150C6AF983: No contact from device>

Could this be a connection issue? Timeout? When I do summon I get a “No contact from device” popup.

You can but I doubt it’ll help. Can you delete the device from Genie and try again? I’d like to see the logs from the very first contact.

Nevermind, I managed to reproduce the issue. Will fix soon. Thanks.

1 Like

Fixed now in latest master. Thanks for your help @sroehrig.

1 Like