IPv6 CWMP Binding

We’re building a IPv6 only lab and need GenieACS to listen on IPv6. It does not seem to do this by default. Does GenieACS support pure-IPv6 only? The environment variables make no reference to IPv6 so I’m trying to verify if IPv6 is a possibility or not.

Nmap scan report for 2605:9fc0:dc1::11
Host is up (0.0045s latency).
All 101 scanned ports on 2605:9fc0:dc1::11 are closed
Nmap scan report for
Host is up (0.00053s latency).
Not shown: 98 closed ports

7547/tcp open cwmp
7557/tcp open unknown
7567/tcp open unknown

We can setup a NAT solution if IPv4 is the only option. The CPE devices are all 100% IPv6 only.

I had it in a docker container for testing purposes.
There IPv6 somehow worked.
At work I am running genieacs behind a nginx, but the server is IPv4 only. It is behind the cgnat so it is not a problem to reach the CPEs.

But I will have a look at IPv6.

This setting is needed in the env file: GENIEACS_CWMP_INTERFACE=::
The nodejs will run in dual stack mode.
This has to be changed for fs service to, with the correct env setting.
I had no problem, connecting over IPv6 to my CPE. The DNS name for this server was ipv6 only.

1 Like

This works. problem solved.

1 Like