I called my virtual parameters but not work

hi
this is my virtual parameter :

and this is how im used that :

please help me this

This is covered in the documentation.

Yes But I cant realize how that work
1 . i writed virtual parameter
2 . i writed a provision for it
3 . and i added a preset for it in perests tab
and in my device ui , i added Virtualparameters.(myparameter namae)

but still not work
Please Help Me At this
Thanks In advanced

1 Like

Yes I read this text and my problem is here that i do not know how do this (fetech)

This is all covered in the documentation.

Which part of documentation mentioned that ?!

Did you add the declare statement for the virtual parameter in your default or inform provision script?

thanks for reply
yes , and i finally did it
but i need to refresh all parameter of a tree (InternetGatewayDevice.Services )too see my virtual parameter value
and for this , i try to add below line to default provision :
declare( “InternetGatewayDevice.Services”, {path: Date.now(), value: Date.now()});
but still dose not work and i should refresh it manually

Can you share your default provision?

i add to line 14 :

It does not show the VirtualParameters.ipa declaration statement.

Here is a snip of my own:

declare(“Device.ManagementServer.PeriodicInformEnable”, {value: daily}, {value: true});
declare(“Device.ManagementServer.PeriodicInformInterval”, {value: daily}, {value: informInterval});
declare(“Device.ManagementServer.PeriodicInformTime”, {value: daily}, {value: informTime});
declare(“VirtualParameters.*”, {value: daily}, {value: informTime});

Thank u i’ll check it
that’s mean this line refresh automatically “internetgatewaydevice.services” tree ?!

Yes it would refresh but if there are too many items within that parameter then only the first 10 or 20 would be displayed. I cannot recall the exact amount that gets displayed so I just used “10 or 20” as an example.

yes thats my problem
is any way to incress this number ?!

From this previous discussion, it seems configurable:

Yes, it is. After Zaidka added it. See original thread - there is Zaidka’s response WHERE to put desired limit.