Connection Request Error After ACS Change: Incorrect Connection Request Credentials

I’m facing an issue with my Zyxel EX3301 which was previously connected to a different Auto Configuration Server (ACS). After changing to a new ACS, I constantly receive an “incorrect connection request credentials” error when attempting to connect.
After the device shows up in the Genie ACS, it seems like the connection should be established, but then the “incorrect connection request credentials” error pops up, preventing any further configuration or management actions.

Could anyone provide specific guidance or steps to troubleshoot this issue? Are there specific settings or configurations within Genie ACS that I need to verify or adjust?

Thank you in advance for any advice or assistance you can offer

thx Daniel

In the ACS world, there are two different authentication pieces. One for ACS → CPE, and one for CPE → ACS.

By default, GenieACS handles setting up the CPE → ACS authentication. Does your CPE require authentication for the ACS to connect to the connection request URL? If so, then you need to set the cwmp.connectionRequestAuth config value with something like this:

AUTH(username, password) OR AUTH("myUsername1", "myPassword1") OR AUTH("myUsername2", "myPassword2")

but i don´t know the username and passwort. Or am I thinking wrong? The CPEs register with the ACS, that works. But then they are not reachable for the ACS and the error message appears: incorrect connection request credentials.
But how am I supposed to know these? The problem only occurs with the Zyxel devices, with the Mikrotik’s the ACS simply overwrites the old data.
Many thanks for your help

As a test, go into the inform provision and comment out the lines that set the ConnectionRequestUsername and ConnectionRequestPassword then connect up your Zyxel. If everything works correctly, then there could be an issue with the Zyxel.

We use the Zyxel VMG4927, 3510 and 5510’s with no issues. I also have my CPEs set to TR-181 to take advantage of the data/features in the newer data model.

Thx for your help. The Problem was:
declare(“InternetGatewayDevice.ManagementServer.PeriodicInformTime”, {value: daily}, {value: informTime});
declare(“Device.ManagementServer.PeriodicInformTime”, {value: daily}, {value: informTime});
in the inform. I disable it, and now it works with Zyxel Devices.

How i can i set my CPE to TR-181?


Ahh yes, I forgot about that. I had to comment out that line as well.

Go to Maintenance → TR-069 Client (you have to be logged in as supervisor user I believe to see this option)

thx and happy Eastern