Can not open genie ULR with last master instalation

Hello

Im trying to install the from git master the version 1.2 under debian 10 , but when try to open the url it would not open the UI. When i change to the installed version from “http://docs.genieacs.com/en/latest/installation-guide.html” , it works.
I don´t know what is wrong, i just need to install the lastest to change the value to dont have the “too_many_rpcs” changing the " lib/session.ts" values, since the installed working version 1.2 does not have.

This are my steps:

root@GenieACS2:/usr/local/lib/node_modules/git clone https://github.com/genieacs/genieacs.git

root@GenieACS2:/usr/local/lib/node_modules/genieacs# npm run build

genieacs@1.2.0-beta.0 build /usr/local/lib/node_modules/genieacs
node -r esm -r ts-node/register/transpile-only build/build

/usr/local/lib/node_modules/genieacs/build/build.ts:84
function rmDirSync(dirPath): void {
^

root@GenieACS2:/usr/local/lib/node_modules/genieacs# npm update
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated mkdirp@0.5.4: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)

core-js@2.6.11 postinstall /usr/local/lib/node_modules/genieacs/node_modules/core-js
node -e “try{require(’./postinstall’)}catch(e){}”

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:

https://opencollective.com/core-js
https://www.patreon.com/zloirock

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/watchpack/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN @typescript-eslint/eslint-plugin@1.13.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @typescript-eslint/parser@1.13.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: chownr@1.1.4 (node_modules/watchpack/node_modules/fsevents/node_modules/chownr):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/chownr-48a3f986’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/chownr’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: ignore-walk@3.0.3 (node_modules/watchpack/node_modules/fsevents/node_modules/ignore-walk):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/ignore-walk-49c0bc3d’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/ignore-walk’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: inherits@2.0.4 (node_modules/watchpack/node_modules/fsevents/node_modules/inherits):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/inherits-244bf81d’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/inherits’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: minimist@1.2.5 (node_modules/watchpack/node_modules/fsevents/node_modules/minimist):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/minimist-ccdccb75’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/minimist’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: ms@2.1.2 (node_modules/watchpack/node_modules/fsevents/node_modules/ms):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/ms-0ed9ef0a’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/ms’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: nopt@4.0.3 (node_modules/watchpack/node_modules/fsevents/node_modules/nopt):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/nopt-80b387d6’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/nopt’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: npm-normalize-package-bin@1.0.1 (node_modules/watchpack/node_modules/fsevents/node_modules/npm-normalize-package-bin):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/npm-normalize-package-bin’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/.npm-normalize-package-bin.DELETE’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: process-nextick-args@2.0.1 (node_modules/watchpack/node_modules/fsevents/node_modules/process-nextick-args):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/process-nextick-args-d48272d6’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/process-nextick-args’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: semver@5.7.1 (node_modules/watchpack/node_modules/fsevents/node_modules/semver):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/semver-2427ee8a’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/semver’
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: yallist@3.1.1 (node_modules/watchpack/node_modules/fsevents/node_modules/yallist):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: no such file or directory, rename ‘/usr/local/lib/node_modules/genieacs/node_modules/.staging/yallist-4c3e4b35’ -> ‘/usr/local/lib/node_modules/genieacs/node_modules/watchpack/node_modules/fsevents/node_modules/yallist’

  • @types/parsimmon@1.10.1
  • @types/koa-router@7.4.0
  • ava@2.4.0
  • @types/mithril@2.0.2
  • codemirror@5.52.2
  • eslint-config-prettier@6.10.1
  • mithril@2.0.4
  • @types/jsonwebtoken@8.3.8
  • @types/koa@2.11.3
  • @types/svgo@1.3.1
  • @types/mongodb@3.5.4
  • koa-bodyparser@4.3.0
  • koa@2.11.0
  • rollup-plugin-terser@5.3.0
  • iconv-lite@0.5.1
  • postcss@7.0.27
  • mongodb@3.5.5
  • ts-node@8.8.1
  • prettier@1.19.1
  • seedrandom@3.0.5
  • svgo@1.3.2
  • rollup@1.32.1
  • webpack@4.42.1
  • yaml@1.8.3
  • typescript@3.8.3
    added 44 packages from 61 contributors, removed 19 packages, updated 195 packages and audited 7508 packages in 77.405s

32 packages are looking for funding
run npm fund for details

found 11 vulnerabilities (10 low, 1 critical)
run npm audit fix to fix them, or npm audit for details

root@GenieACS2:/usr/local/lib/node_modules/genieacs# npm install

npm WARN @typescript-eslint/eslint-plugin@1.13.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @typescript-eslint/parser@1.13.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.12 (node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

audited 7508 packages in 21.906s

31 packages are looking for funding
run npm fund for details

found 11 vulnerabilities (10 low, 1 critical)
run npm audit fix to fix them, or npm audit for details
root@GenieACS2:/usr/local/lib/node_modules/genieacs# npm run build

genieacs@1.2.0-beta.0 build /usr/local/lib/node_modules/genieacs
node -r esm -r ts-node/register/transpile-only build/build

Browserslist: caniuse-lite is outdated. Please run next command npm update

Hash: 63d18392b83c9944b37a
Version: webpack 4.42.1
Time: 40708ms
Built at: 2020-03-28 14:14:19
Asset Size Chunks Chunk Names
1.app.js 184 KiB 1 [emitted] vendors~codemirror
1.app.js.map 290 KiB 1 [emitted] [dev] vendors~codemirror
2.app.js 94.7 KiB 2 [emitted] vendors~yaml
2.app.js.map 127 KiB 2 [emitted] [dev] vendors~yaml
app.js 170 KiB 0 [emitted] main
app.js.map 246 KiB 0 [emitted] [dev] main
Entrypoint main = app.js app.js.map
[0] ./node_modules/mithril/index.js 756 bytes {0} [built]
[1] ./node_modules/parsimmon/build/parsimmon.umd.min.js 14.3 KiB {0} [built]
[2] ./node_modules/mithril/render/vnode.js 1.17 KiB {0} [built]
[4] ./node_modules/mithril/mount-redraw.js 135 bytes {0} [built]
[5] ./node_modules/mithril/pathname/build.js 1.73 KiB {0} [built]
[6] ./node_modules/mithril/pathname/parse.js 657 bytes {0} [built]
[10] ./node_modules/mithril/promise/polyfill.js 3.71 KiB {0} [built]
[12] ./node_modules/mithril/render.js 66 bytes {0} [built]
[13] ./node_modules/mithril/querystring/build.js 672 bytes {0} [built]
[15] ./node_modules/mithril/querystring/parse.js 1.36 KiB {0} [built]
[17] ./dist/public/app.js 303 KiB {0} [built]
[33] ./node_modules/codemirror/lib/codemirror.js 387 KiB {1} [built]
[34] ./node_modules/codemirror/mode/javascript/javascript.js 36.7 KiB {1} [built]
[35] ./node_modules/codemirror/mode/yaml/yaml.js 3.65 KiB {1} [built]
[36] ./node_modules/yaml/index.js 43 bytes {2} [built]
+ 76 hidden modules
root@GenieACS2:/usr/local/lib/node_modules/genieacs#

Also (trying several times to install via git clone, and add service and all… ) always i get this:

root@GenieACS2:~# sudo systemctl status genieacs-cwmp
● genieacs-cwmp.service - GenieACS CWMP
Loaded: loaded (/etc/systemd/system/genieacs-cwmp.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2020-03-29 12:43:47 -03; 1min 4s ago
Process: 332 ExecStart=/usr/local/lib/node_modules/genieacs/bin/genieacs-cwmp (code=exited, status=1/FAILURE)
Main PID: 332 (code=exited, status=1/FAILURE)

mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: at Module.require (internal/modules/cjs/loader.js:1044:19)
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: at Module._preloadModules (internal/modules/cjs/loader.js:1298:12)
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: at loadPreloadModules (internal/bootstrap/pre_execution.js:444:5)
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: at prepareMainThreadExecution (internal/bootstrap/pre_execution.js:68:3)
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: at internal/main/run_main_module.js:7:1 {
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: code: ‘MODULE_NOT_FOUND’,
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: requireStack: [ ‘internal/preload’ ]
mar 29 12:43:47 GenieACS2 genieacs-cwmp[332]: }