Genieacs-cwmp process dies and restarts

Seems there is a bug somewhere… I see these in my logs, but I’m not sure what file it’s barfing on:
sep. 11 09:44:30 tinn-acs genieacs-cwmp[5468]: 2019-09-11T07:44:30.623Z [ERROR] Uncaught exception; pid=4689 exceptionName=“SyntaxError” exceptionMessage=“Unexpected token o in JSON at position 1” exceptionStack=“SyntaxError: Unexpected token o in JSON at position 1\n at JSON.parse ()\n at getDueTasksAndFaultsAndOperations (/opt/genieacs/dist/bin/genieacs-cwmp:2:124714)\n at process._tickCallback (internal/process/next_tick.js:68:7)”

sep. 11 09:44:30 tinn-acs genieacs-cwmp[5468]: 2019-09-11T07:44:30.653Z [ERROR] Worker died; pid=4689 exitCode=0

Hi all,

I’m facing the same error in my setup. Don’t know what is the cause. I’ve tried debugging with tcpdump and I see the output seen in

If I copy the xml code and post it with curl I can’t recreate the problem.

Thanks in advance!
Janko Bajc

I figured this one out after a while, but I don’t remember how… I think there was a typo in my config, but I’m not sure. I’ll see if I can figure it out (I got it working and haven’t seen this problem since)

Please let me know if you find anything. I’m puzzled. All I can see for now is that it only appears with CPEs connected behind NAT (CGN).
Thanks again.

Upgrade to the latest commit has solved my issue.

1 Like